WorksharingUtilsGetWorksharingTooltipInfo Method |
Gets worksharing information about an element to display in an in-canvas tooltip.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static WorksharingTooltipInfo GetWorksharingTooltipInfo(
Document document,
ElementId elementId
)
Public Shared Function GetWorksharingTooltipInfo (
document As Document,
elementId As ElementId
) As WorksharingTooltipInfo
public:
static WorksharingTooltipInfo^ GetWorksharingTooltipInfo(
Document^ document,
ElementId^ elementId
)
static member GetWorksharingTooltipInfo :
document : Document *
elementId : ElementId -> WorksharingTooltipInfo
Parameters
- document Document
-
The document containing the element
- elementId ElementId
-
The id of the element in question
Return Value
WorksharingTooltipInfo
Worksharing information about the specified element.
Exceptions
Remarks If there is no element corresponding to the given id,
then all the strings returned in WorksharingTooltipInfo are empty.
The return value may not be dependable in the middle of a transaction.
See the remarks on WorksharingUtils for more details.
See Also