BuiltInFailuresFabricFailures Class

Failures about Fabric.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBBuiltInFailuresFabricFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static class FabricFailures

The BuiltInFailuresFabricFailures type exposes the following members.

Properties
 NameDescription
Public propertyStatic memberBendDiameterNegative Fabric Bend Diameter is negative.
Public propertyStatic memberBendPolylineInvalid The bend profile contains too short of a segment to apply the wire bend diameter. Cannot create a bent fabric sheet for this type.
Public propertyStatic memberBentHiddenWires The wires of this custom fabric sheet type are longer than the bending sketch. The linear quantities shown in schedules and tags are not accurate.
Public propertyStatic memberCannotPlaceFabricArea Can't find a host for Fabric Area.
Public propertyStatic memberCannotPlaceFabricAreaWarn Can't find a host for Fabric Area.
Public propertyStatic memberCannotPlaceFabricSheet Can't find a host for Fabric Sheet.
Public propertyStatic memberCannotPlaceFabricSheetWarn Can't find a host for Fabric Sheet.
Public propertyStatic memberCoverOffsetTooLong Cover offset is greater than host thickness.
Public propertyStatic memberCoverOffsetTooLongTemp Cover offset is greater than host thickness - support for transient Single Fabric Sheet in editor.
Public propertyStatic memberFabricAreaWrongHost Fabric Area can be placed only in Structural Floors and straight Structural Walls.
Public propertyStatic memberFabricAreaWrongLapSplice Fabric Area Sheet lap splice is incorrect. Can't create Fabric Area.
Public propertyStatic memberFabricAreaWrongSheetAlignment Fabric Area Sheet Alignment is incorrect. Can't create Fabric Area.
Public propertyStatic memberFabricSheetWrongHost Fabric Sheet can be placed only in Structural Floors and straight Structural Walls.
Public propertyStatic memberMajorLapSpliceFailure The lap splice in the major direction is greater than the half of the overall length.
Public propertyStatic memberMajorOverhangFailure At least one of the overhangs in the major direction is lower than radius of the wire in the minor direction.
Public propertyStatic memberMajorSpacingFailure The spacing in the major direction is lower than diameter of the wire in the minor direction.
Public propertyStatic memberMinorLapSpliceFailure The lap splice in the minor direction is greater than the half of the overall width.
Public propertyStatic memberMinorOverhangFailure At least one of the overhangs in the minor direction is lower than radius of the wire in the major direction.
Public propertyStatic memberMinorSpacingFailure The spacing in the minor direction is lower than diameter of the wire in the major direction.
Public propertyStatic memberNoSurfPatternOnWire Wire elements do not support surface patterns. The surface pattern associated with this material will not be displayed on the indicated Fabric Sheet Type.
Public propertyStatic memberNoWireMaterialDensity Material does not have a density defined. The weight of the Fabric Sheet cannot be computed.
Public propertyStatic memberWireDiameterTooLarge Fabric Wire Diameter is too large.
Public propertyStatic memberWrongFabricSheetEndOverhang Wrong Start Overhang of the Fabric Sheet Type.
Public propertyStatic memberWrongFabricSheetLayoutPattern The Layout Pattern cannot accommodate the current data. Try decreasing the Number of Wires/Spacing.
Public propertyStatic memberWrongFabricSheetNumberOfWires Wrong Number of Wires of the Fabric Sheet Type.
Public propertyStatic memberWrongFabricSheetOverallLength Wrong Overall Length/Width of the Fabric Sheet Type.
Public propertyStatic memberWrongFabricSheetSpacing Wrong Spacing of the Fabric Sheet Type.
Public propertyStatic memberWrongFabricSheetStartOverhang Wrong Start Overhang of the Fabric Sheet Type.
Top
See Also