KeyBasedTreeEntry Class

A key-based tree entry, containing the key, parent key, and children keys (if applicable).
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBKeyBasedTreeEntry
    Autodesk.Revit.DBClassificationEntry
    Autodesk.Revit.DBKeynoteEntry

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class KeyBasedTreeEntry : IDisposable

The KeyBasedTreeEntry type exposes the following members.

Properties
 NameDescription
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public propertyKey The key of this entry.
Public propertyParentKey The parent key of this entry.
Top
Methods
 NameDescription
Public methodDisposeReleases all resources used by the KeyBasedTreeEntry
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetChildrenKeys Gets a collection containing the keys of all children entry objects from this entry.
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
See Also