WorksharingUtilsGetCheckoutStatus(Document, ElementId) Method

Gets the ownership status of an element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static CheckoutStatus GetCheckoutStatus(
	Document document,
	ElementId elementId
)

Parameters

document  Document
The document containing the element.
elementId  ElementId
The id of the element.

Return Value

CheckoutStatus
A summary of whether the element is unowned, owned by the current user, or owned by another user.
Exceptions
ExceptionCondition
ArgumentNullException A non-optional argument was null
Remarks

This method returns a locally cached value which may not be up to date with the current state of the element in the central. Because of this, the return value is suitable for reporting to an interactive user (e.g. via a mechanism similar to Worksharing display mode), but cannot be considered a reliable indication of whether the element can be immediately edited by the application. Also, the return value may not be dependable in the middle of a local transaction. See the remarks on WorksharingUtils for more details.

For performance reasons, the model is not validated to be workshared, and the element id is also not validated; the element will not be expanded.

See Also