NonContinuousRailInfoMaterialId Property

The material id associated with the non-continuous rail, or invalidElementId if none.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public ElementId MaterialId { get; set; }

Property Value

ElementId
Exceptions
ExceptionCondition
ArgumentException When setting this property: The materialId is not a valid value to be used as a non-continuous rail material Id.
ArgumentNullException When setting this property: A non-optional argument was null
See Also