IExternalApplication Interface |
An interface that supports addition of external applications to Revit.
Namespace: Autodesk.Revit.UIAssembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic interface IExternalApplication
Public Interface IExternalApplication
public interface class IExternalApplication
type IExternalApplication = interface end
The IExternalApplication type exposes the following members.
Methods | Name | Description |
---|
 | OnShutdown | Implement this method to execute some tasks when Autodesk Revit shuts down. |
 | OnStartup | Implement this method to execute some tasks when Autodesk Revit starts. |
Top
RemarksExternal applications are permitted to customize the Revit UI, and to add events
and updaters to the session.
See Also