ViewIsElementVisibleInTemporaryViewMode Method |
Identifies if the input element is visible for the temporary view mode for this view.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic bool IsElementVisibleInTemporaryViewMode(
TemporaryViewMode mode,
ElementId id
)
Public Function IsElementVisibleInTemporaryViewMode (
mode As TemporaryViewMode,
id As ElementId
) As Boolean
public:
bool IsElementVisibleInTemporaryViewMode(
TemporaryViewMode mode,
ElementId^ id
)
member IsElementVisibleInTemporaryViewMode :
mode : TemporaryViewMode *
id : ElementId -> bool
Parameters
- mode TemporaryViewMode
-
The temporary view mode. Only TemporaryHideIsolate and AnalyticalModel modes are supported
by this option. Other modes will result in an exception.
- id ElementId
-
The element id.
Return Value
Boolean
True if the element is visible, false if the element is hidden in the view mode.
Exceptions
See Also