DocumentNewFamilyInstance(XYZ, FamilySymbol, Element, Level, StructuralType) Method |
Inserts a new instance of a family into the document,
using a location, type/symbol, the host element and a base level.
Namespace: Autodesk.Revit.CreationAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic FamilyInstance NewFamilyInstance(
XYZ location,
FamilySymbol symbol,
Element host,
Level level,
StructuralType structuralType
)
Public Function NewFamilyInstance (
location As XYZ,
symbol As FamilySymbol,
host As Element,
level As Level,
structuralType As StructuralType
) As FamilyInstance
public:
FamilyInstance^ NewFamilyInstance(
XYZ^ location,
FamilySymbol^ symbol,
Element^ host,
Level^ level,
StructuralType structuralType
)
member NewFamilyInstance :
location : XYZ *
symbol : FamilySymbol *
host : Element *
level : Level *
structuralType : StructuralType -> FamilyInstance
Parameters
- location XYZ
- The physical location where the instance is to be placed on the specified level.
- symbol FamilySymbol
- A FamilySymbol object that represents the type of the instance that is to be inserted.
- host Element
- A host object into which the instance will be embedded
- level Level
- A Level object that is used as the base level for the object.
- structuralType StructuralType
- If structural then specify the type of the component.
Return Value
FamilyInstanceIf creation was successful then an instance to the new object is returned, otherwise
.
Exceptions
RemarksThis form of NewFamilyInstance is the most commonly used in Autodesk Revit since there are
a large number of elements that use levels, such as Walls, Columns etc. If the instance fails to
be created an exception may be thrown.
The type/symbol that is used must be loaded into the document
before this method is called. Families and their symbols can be loaded using the Document.LoadFamily
or Document.LoadFamilySymbol methods.
All levels within the document can be found by iterating over
the entire document and searching for objects of type Autodesk.Revit.Elements.Level.
Some Families, such as Beams, have more than one endpoint and are inserted in the same manner as single point
instances. Once inserted these linear family instances can have their endpoints changed by using
the instance's Element.Location property.
Note: ForbiddenForDynamicUpdateException might be thrown during a dynamic update if the inserted instance establishes a mutual dependency with another structure.
Note: if the created family instance includes nested instances, the API framework will automatically regenerate
the document during this method call.
Examplevoid CreateDoorsInWall(Autodesk.Revit.DB.Document document, Wall wall)
{
Level level = document.GetElement(wall.LevelId) as Level;
FilteredElementCollector collector = new FilteredElementCollector(document);
ICollection<Element> collection = collector.OfClass(typeof(FamilySymbol))
.OfCategory(BuiltInCategory.OST_Doors)
.ToElements();
IEnumerator<Element> symbolItor = collection.GetEnumerator();
double x = 0, y = 0, z = 0;
while (symbolItor.MoveNext())
{
FamilySymbol symbol = symbolItor.Current as FamilySymbol;
XYZ location = new XYZ(x, y, z);
FamilyInstance instance = document.Create.NewFamilyInstance(location, symbol, wall, level, StructuralType.NonStructural);
x += 10;
y += 10;
z += 1.5;
}
}
Private Sub CreateDoorsInWall(document As Autodesk.Revit.DB.Document, wall As Wall)
Dim level As Level = TryCast(document.GetElement(wall.LevelId), Level)
Dim collector As New FilteredElementCollector(document)
Dim collection As ICollection(Of Element) = collector.OfClass(GetType(FamilySymbol)).OfCategory(BuiltInCategory.OST_Doors).ToElements()
Dim symbolItor As IEnumerator(Of Element) = collection.GetEnumerator()
Dim x As Double = 0, y As Double = 0, z As Double = 0
While symbolItor.MoveNext()
Dim symbol As FamilySymbol = TryCast(symbolItor.Current, FamilySymbol)
Dim location As New XYZ(x, y, z)
Dim instance As FamilyInstance = document.Create.NewFamilyInstance(location, symbol, wall, level, StructuralType.NonStructural)
x += 10
y += 10
z += 1.5
End While
End Sub
No code example is currently available or this language may not be supported.
No code example is currently available or this language may not be supported.
See Also