FilterStringRule Class

A filter rule that operates on string values in a Revit project.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBFilterRule
    Autodesk.Revit.DBFilterValueRule
      Autodesk.Revit.DBFilterStringRule

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class FilterStringRule : FilterValueRule

The FilterStringRule type exposes the following members.

Constructors
 NameDescription
Public methodFilterStringRule Constructs an instance of FilterStringRule.
Top
Properties
 NameDescription
Public propertyRuleString The user-supplied string against which strings from a Revit document will be tested.
Top
Methods
 NameDescription
Public methodGetEvaluator Gets the evaluator that implements the test for this rule.
Public methodSetEvaluator Sets the evaluator that implements the test for this rule.
Top
Remarks
All string comparisons in this class are performed in the case-insensitive manner.
See Also