FilterStringRule Class

A filter rule that operates on string values in a Revit project.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBFilterRule
    Autodesk.Revit.DBFilterValueRule
      Autodesk.Revit.DBFilterStringRule

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class FilterStringRule : FilterValueRule

The FilterStringRule type exposes the following members.

Constructors
 NameDescription
Public methodFilterStringRule Constructs an instance of FilterStringRule.
Top
Properties
 NameDescription
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
(Inherited from FilterRule)
Public propertyRuleString The user-supplied string against which strings from a Revit document will be tested.
Top
Methods
 NameDescription
Public methodDispose
(Inherited from FilterRule)
Public methodElementPasses Derived classes override this method to implement the test that determines whether the given element passes this rule or not.
(Inherited from FilterRule)
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetEvaluator Gets the evaluator that implements the test for this rule.
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetRuleParameter Returns the ElementId of the parameter associated to this FilterRule if there is one, or invalidElementId if there is no associated parameter.
(Inherited from FilterRule)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodSetEvaluator Sets the evaluator that implements the test for this rule.
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
Remarks
All string comparisons in this class are performed in the case-insensitive manner.
See Also