MultiReferenceAnnotationIsLinearFixedDimensionDirectionValid Method |
If the DimensionStyleType is LinearFixed, this function verifies that the dimension line direction
matches either the view's vertical or horizontal direction.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static bool IsLinearFixedDimensionDirectionValid(
Document document,
ElementId viewId,
MultiReferenceAnnotationOptions options
)
Public Shared Function IsLinearFixedDimensionDirectionValid (
document As Document,
viewId As ElementId,
options As MultiReferenceAnnotationOptions
) As Boolean
public:
static bool IsLinearFixedDimensionDirectionValid(
Document^ document,
ElementId^ viewId,
MultiReferenceAnnotationOptions^ options
)
static member IsLinearFixedDimensionDirectionValid :
document : Document *
viewId : ElementId *
options : MultiReferenceAnnotationOptions -> bool
Parameters
- document Document
-
The document for the view.
- viewId ElementId
-
The view in which the dimension line direction will be tested.
- options MultiReferenceAnnotationOptions
-
Options containing the DimensionStyleType and dimension line direction to test.
Return Value
Boolean
True if the DimensionStyleType is LinearFixed and the dimension line direction can be used in the view.
True if the DimensionStyleType is not LinearFixed.
Exceptions
See Also