DocumentNewCurtainSystem Method |
Creates a new CurtainSystem element from a set of faces.
Namespace: Autodesk.Revit.CreationAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic CurtainSystem NewCurtainSystem(
FaceArray faces,
CurtainSystemType curtainSystemType
)
Public Function NewCurtainSystem (
faces As FaceArray,
curtainSystemType As CurtainSystemType
) As CurtainSystem
public:
CurtainSystem^ NewCurtainSystem(
FaceArray^ faces,
CurtainSystemType^ curtainSystemType
)
member NewCurtainSystem :
faces : FaceArray *
curtainSystemType : CurtainSystemType -> CurtainSystem
Parameters
- faces FaceArray
- The faces new CurtainSystem will be created on.
- curtainSystemType CurtainSystemType
- The Type of CurtainSystem to be created.
Return Value
CurtainSystem The CurtainSystem created will be returned when the operation succeeds.
ExceptionsException | Condition |
---|
ArgumentNullException |
Thrown in following cases:
The input argument faces or curtainSystemType is .
The size of faces is zero.
|
InvalidOperationException |
Thrown when the CurtainSystem cannot be created or regenerate fails.
|
ArgumentException | Thrown if the curtain system type does not exist in the given document. |
Remarks The input faces will be copied during the operations so that they can be any
faces.
See Also