ExporterIFCUtilsIsWallBaseRectangular Method |
Identifies if the wall's base can be represented by a direct thickening of the wall's base curve.
Namespace: Autodesk.Revit.DB.IFCAssembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static bool IsWallBaseRectangular(
Wall wall,
Curve curve
)
Public Shared Function IsWallBaseRectangular (
wall As Wall,
curve As Curve
) As Boolean
public:
static bool IsWallBaseRectangular(
Wall^ wall,
Curve^ curve
)
static member IsWallBaseRectangular :
wall : Wall *
curve : Curve -> bool
Parameters
- wall Wall
-
The wall.
- curve Curve
-
The wall's base curve.
Return Value
Boolean
True if the wall's base can be represented by a direct thickening of the wall's base curve.
False if the wall's base shape is affected by other geometry, and thus cannot be represented
by a direct thickening of the wall's base cure.
Exceptions
See Also