ExporterIFCGetOrCreateFillPattern Method |
Get (or create) the IfcFillPatternStyle associated with an ElementId.
Namespace: Autodesk.Revit.DB.IFCAssembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic IFCAnyHandle GetOrCreateFillPattern(
ElementId fillPatternId,
Color color,
double planScale
)
Public Function GetOrCreateFillPattern (
fillPatternId As ElementId,
color As Color,
planScale As Double
) As IFCAnyHandle
public:
IFCAnyHandle^ GetOrCreateFillPattern(
ElementId^ fillPatternId,
Color^ color,
double planScale
)
member GetOrCreateFillPattern :
fillPatternId : ElementId *
color : Color *
planScale : float -> IFCAnyHandle
Parameters
- fillPatternId ElementId
-
The fill pattern id.
- color Color
-
The pattern color.
- planScale Double
-
The view scale.
Return Value
IFCAnyHandle
The IfcSurfaceStyle.
Exceptions
See Also