ExternalEventRaise Method |
Instructing Revit to raise (signal) the external event.
Namespace: Autodesk.Revit.UIAssembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic ExternalEventRequest Raise()
Public Function Raise As ExternalEventRequest
public:
ExternalEventRequest Raise()
member Raise : unit -> ExternalEventRequest
Return Value
ExternalEventRequest
The result of event raising request. If the request is 'Accepted',
the event would be added to the event queue and its handler will
be executed in the next event-processing cycle.
Remarks
Revit will wait until it is ready to process the event and then
it will execute its event handler by calling the Execute method.
Revit processes external events only when no other commands or
edit modes are currently active in Revit, which is the same policy
like the one that applies to evoking external commands.
See Also