ExternalEvent Class

A class that represent an external event.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.UIExternalEvent

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class ExternalEvent : IDisposable

The ExternalEvent type exposes the following members.

Properties
 NameDescription
Public propertyIsPending Checking whether an event has been raised but not yet executed.
Top
Methods
 NameDescription
Public methodStatic memberCreate Creates an instance of external event.
Public methodStatic memberCreateJournalable Creates an instance of external event which will have the ability to record its executions in the journal.
Public methodDisposeReleases all resources used by the ExternalEvent
Public methodRaise Instructing Revit to raise (signal) the external event.
Top
Remarks
An instance if this class will be returned to an external event's owner upon the event's creation. The event's owner will use this instance to signal that his application needs to be called by Revit. Revit will periodically check if any of the events have been signaled (raised), and will execute all events that were signaled (raised) by calling the Execute method on the events' respective handlers.
See Also