ExternalEventRequest Enumeration |
Represents the possible outcomes of a request for raising an external event.
Namespace: Autodesk.Revit.UIAssembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic enum ExternalEventRequest
Public Enumeration ExternalEventRequest
public enum class ExternalEventRequest
type ExternalEventRequest
MembersMember name | Value | Description |
---|
Accepted | 0 |
Request accepted; event was added into the event queue and will be executed momentarily.
|
Pending | 1 |
Request not accepted, because the previous request is still pending (not executed).
|
Denied | 2 |
Request was denied due to failures of the corresponding event handler.
|
TimedOut | 3 |
Request not accepted due to synchronization issues with other thread(s).
|
See Also