ApplicationNewFamilySymbolProfile Method

Creates a new FamilySymbolProfile object.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public FamilySymbolProfile NewFamilySymbolProfile(
	FamilySymbol familySymbol
)

Parameters

familySymbol  FamilySymbol
The family symbol of the Profile.

Return Value

FamilySymbolProfile
The new FamilySymbolProfile object.
Exceptions
ExceptionCondition
ArgumentNullException Thrown when the argument familySymbol is .
See Also