SolidGeometryOptions Class

A class containing optional information to control the geometry generation of the Solid by the SolidUtils routines.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBSolidGeometryOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class SolidGeometryOptions : IDisposable

The SolidGeometryOptions type exposes the following members.

Constructors
 NameDescription
Public methodSolidGeometryOptions Creates a new SolidOptions class with solid tag settings.
Top
Properties
 NameDescription
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public propertySolidTag Optional solid tag for the Solid.
Top
Methods
 NameDescription
Public methodDisposeReleases all resources used by the SolidGeometryOptions
Top
See Also