AddInId Class

Identifies an AddIn registered with Revit
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBAddInId

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class AddInId : IDisposable

The AddInId type exposes the following members.

Constructors
 NameDescription
Public methodAddInId creates an AddInId object with a given GUID
Top
Properties
 NameDescription
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 NameDescription
Public methodDisposeReleases all resources used by the AddInId
Public methodGetAddInName name of addin associated with this AddInId Attempts to obtain the name from loaded Third Party AddIns
Public methodGetAddInNameFromDocument name of application associated with this ApplicationId First attempts to obtain the name from AddInIds stored in the document. If unsuccessful, attempts to obtain the name from loaded Third Party AddIns.
Public methodGetGUID value of the AddInId as a GUID
Top
See Also