DirectContext3DHandleOverridesGetDirectContext3DHandleSettings Method

Gets override settings associated with a DirectContext3D handle instance or type.

Namespace: Autodesk.Revit.DB.DirectContext3D
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public DirectContext3DHandleSettings GetDirectContext3DHandleSettings(
	Document aDoc,
	ElementId elementId
)

Parameters

aDoc  Document
Document where elementId resides.
elementId  ElementId
Id of the overridden element.

Return Value

DirectContext3DHandleSettings
The override settings assigned to the handle element, if present, or a default override settings if nothing was found.
Exceptions
ExceptionCondition
ArgumentException The ElementId elementId is not a valid DirectContext3D handle instance or type.
ArgumentNullException A non-optional argument was null
See Also