ViewOrientation3D Class

Container for the point and vectors which define View3D's orientation.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBViewOrientation3D

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class ViewOrientation3D : IDisposable

The ViewOrientation3D type exposes the following members.

Constructors
 NameDescription
Public methodViewOrientation3D Constructs a new ViewOrientation3D using the input eye position, up and forward directions.
Top
Properties
 NameDescription
Public propertyEyePosition The eye position point
Public propertyForwardDirection The forward direction vector
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public propertyUpDirection The up direction vector
Top
Methods
 NameDescription
Public methodDisposeReleases all resources used by the ViewOrientation3D
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
See Also