ViewOrientation3D Constructor

Constructs a new ViewOrientation3D using the input eye position, up and forward directions.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public ViewOrientation3D(
	XYZ eyePosition,
	XYZ upDirection,
	XYZ forwardDirection
)

Parameters

eyePosition  XYZ
The eye position
upDirection  XYZ
The up direction. This vector will be normalized. Up direction must be perpendicular to the forward direction.
forwardDirection  XYZ
The forward direction. This vector will be normalized. Forward direction must be perpendicular to the up direction.
Exceptions
ExceptionCondition
ArgumentException One or both of the input vectors cannot be normalized.
ArgumentNullException A non-optional argument was null
ArgumentOutOfRangeException upDirection has zero length. -or- forwardDirection has zero length.
ArgumentsInconsistentException The vectors upDirection and forwardDirection are not perpendicular.
See Also