CurtainGridChangePanelType Method |
Change the type of a curtain panel.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic Element ChangePanelType(
Element panel,
ElementType newSymbol
)
Public Function ChangePanelType (
panel As Element,
newSymbol As ElementType
) As Element
public:
Element^ ChangePanelType(
Element^ panel,
ElementType^ newSymbol
)
member ChangePanelType :
panel : Element *
newSymbol : ElementType -> Element
Parameters
- panel Element
- The panel to be changed, it can be a type of Panel or Wall.
- newSymbol ElementType
- The new symbol, it may be of PanelType or WallType when the panel is hosted in a curtain wall.
The new symbol can only be of type PanelType if the Panel is hosted in a curtain system.
Return Value
Element If operation succeeds, the modified panel element is returned.
Exceptions
See Also