Picks an element to support the slab. This method will define split lines and create constant bearing lines for the slab.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public void PickSupport( Line gLine ) |
Visual Basic |
---|
Public Sub PickSupport ( _ gLine As Line _ ) |
Visual C++ |
---|
public: void PickSupport( Line^ gLine ) |
Parameters
- gLine
- Type: Autodesk.Revit.DB..::..Line
A line from a support element such as a beam.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the input line is nullNothingnullptra null reference (Nothing in Visual Basic). |
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the input line is invalid. |