Sets the Building Construction of the Project Information.
Namespace: Autodesk.Revit.DB.MechanicalAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public void SetBuildingConstruction( ConstructionType constructionType, Construction buildingConstruction ) |
Visual Basic |
---|
Public Sub SetBuildingConstruction ( _ constructionType As ConstructionType, _ buildingConstruction As Construction _ ) |
Visual C++ |
---|
public: void SetBuildingConstruction( ConstructionType constructionType, Construction^ buildingConstruction ) |
Parameters
- constructionType
- Type: Autodesk.Revit.DB.Analysis..::..ConstructionType
The Construction Type of Building Construction.
- buildingConstruction
- Type: Autodesk.Revit.DB..::..Construction
The Building Construction to be set.
Remarks
This function is used to set the Building Construction of the Project Information.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | buildingConstruction is NULL. |
Autodesk.Revit.Exceptions..::..InvalidOperationException | Sets construction type to an invalid value. - or - Can not set construction type. |