Gets the line pattern id associated with this category for the given graphics style type.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2017
Syntax
C# |
---|
public ElementId GetLinePatternId( GraphicsStyleType graphicsStyleType ) |
Visual Basic |
---|
Public Function GetLinePatternId ( _ graphicsStyleType As GraphicsStyleType _ ) As ElementId |
Visual C++ |
---|
public: ElementId^ GetLinePatternId( GraphicsStyleType graphicsStyleType ) |
Parameters
- graphicsStyleType
- Type: Autodesk.Revit.DB..::..GraphicsStyleType
The type of graphics style.
Return Value
Returns the line pattern id associated with this category for the given graphics style type.
Remarks
- The line pattern id will be one of the following:
- A negative value (representing a built-in line pattern)
- The id of a LinePatternElement
- InvalidElementId, indicating that this category does not have a stored line pattern id for this graphics style type.