CategoryGetLinePatternId Method |
Gets the line pattern id associated with this category for the given graphics style type.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic ElementId GetLinePatternId(
GraphicsStyleType graphicsStyleType
)
Public Function GetLinePatternId (
graphicsStyleType As GraphicsStyleType
) As ElementId
public:
ElementId^ GetLinePatternId(
GraphicsStyleType graphicsStyleType
)
member GetLinePatternId :
graphicsStyleType : GraphicsStyleType -> ElementId
Parameters
- graphicsStyleType GraphicsStyleType
- The type of graphics style.
Return Value
ElementIdReturns the line pattern id associated with this category for the given graphics style type.
Remarks- The line pattern id will be one of the following:
- A negative value (representing a built-in line pattern)
- The id of a LinePatternElement
- InvalidElementId, indicating that this category does not have a stored line pattern id for this graphics style type.
See Also