Get the integer value for an overriden parameter.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2018
Syntax
C# |
---|
public int GetIntOverrideValue( ElementId paramId ) |
Visual Basic |
---|
Public Function GetIntOverrideValue ( _ paramId As ElementId _ ) As Integer |
Visual C++ |
---|
public: int GetIntOverrideValue( ElementId^ paramId ) |
Parameters
- paramId
- Type: Autodesk.Revit.DB..::..ElementId
The id of the parameter
Return Value
The override value of the parameter.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | paramId is not the id of a parameter in the current document, or its value type is not integer. -or- paramId is not a Rebar Container parameter -or- paramId has no override |
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |