Force the IFC file to be imported regardless of an existing corresponding Revit file.
Namespace: Autodesk.Revit.DB.IFCAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2015
Syntax
C# |
---|
public bool ForceImport { get; set; } |
Visual Basic |
---|
Public Property ForceImport As Boolean Get Set |
Visual C++ |
---|
public: property bool ForceImport { bool get (); void set (bool value); } |
Remarks
If this value is true (default), we will perform the import even if the existing corresponding Revit file is up-to-date.
If this value is false, then we will re-use an existing RVT file if it is up-to-date.
The intention is for ForceImport to be false during host file open while reloading links,
and true during link reload via the Manage Links API.