Applies the previously set changes to the selection of fabrication parts to change the size, change the service, or both.
Namespace: Autodesk.Revit.DB.FabricationAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2018.2
Syntax
C# |
---|
public FabricationNetworkChangeServiceResult ApplyChange() |
Visual Basic |
---|
Public Function ApplyChange As FabricationNetworkChangeServiceResult |
Visual C++ |
---|
public: FabricationNetworkChangeServiceResult ApplyChange() |
Remarks
After this method has been invoked, call:
- GetStraightsThatWereNotChanged()()()() to get a set of fabrication part straight element identifiers that were not changed.
- [!:GetElementsThatHadFailures] to get a set of fabrication part element identifiers that had failures.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | The selection contains invalid elements to change. |
Autodesk.Revit.Exceptions..::..InvalidOperationException | No fabrication configuration is loaded. |