A geometry vertex specified as a position in space with a color.

Namespace: Autodesk.Revit.DB.DirectContext3D
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:  2017

Syntax

C#
public class VertexPositionColored : Vertex
Visual Basic
Public Class VertexPositionColored _
	Inherits Vertex
Visual C++
public ref class VertexPositionColored : public Vertex

Remarks

The color of these vertices includes a transparency component In order to render them as transparent they must be rendered in the transparent pass See the 'IsTransparentPass' method of DrawContext

Inheritance Hierarchy

System..::..Object
  Autodesk.Revit.DB.DirectContext3D..::..Vertex
    Autodesk.Revit.DB.DirectContext3D..::..VertexPositionColored

See Also