VertexPositionColored Class

A geometry vertex specified as a position in space with a color.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DB.DirectContext3DVertex
    Autodesk.Revit.DB.DirectContext3DVertexPositionColored

Namespace: Autodesk.Revit.DB.DirectContext3D
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class VertexPositionColored : Vertex

The VertexPositionColored type exposes the following members.

Constructors
 NameDescription
Public methodVertexPositionColored Constructs the vertex from a point and a color.
Top
Properties
 NameDescription
Public propertyPosition The vertex's position.
Top
Methods
 NameDescription
Public methodGetColor Gets the vertex's color.
Public methodStatic memberGetSizeInFloats Gets the amount of storage that the vertex takes up in a buffer, measured in floats.
Public methodSetColor Sets the vertex's color.
Top
Remarks
The color of these vertices includes a transparency component In order to render them as transparent they must be rendered in the transparent pass See the 'IsTransparentPass' method of DrawContext
See Also