Get all the custom Panels on Add-Ins tab of Revit.
Namespace: Autodesk.Revit.UIAssembly: RevitAPIUI (in RevitAPIUI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public virtual List<RibbonPanel> GetRibbonPanels() |
Visual Basic |
---|
Public Overridable Function GetRibbonPanels As List(Of RibbonPanel) |
Visual C++ |
---|
public: virtual List<RibbonPanel^>^ GetRibbonPanels() |
Remarks
The built-in panels won't be included and the panels added to tabs other than Add-Ins will not be included.
This method is not supported in Macros.