A value that controls render duration.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2017
Syntax
C# |
---|
public RenderDuration RenderDuration { get; set; } |
Visual Basic |
---|
Public Property RenderDuration As RenderDuration Get Set |
Visual C++ |
---|
public: property RenderDuration RenderDuration { RenderDuration get (); void set (RenderDuration value); } |
Remarks
The duration of rendering.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | When setting this property: The value is not valid for RenderDuration. -or- When setting this property: A value passed for an enumeration argument is not a member of that enumeration |
Autodesk.Revit.Exceptions..::..InvalidOperationException | When setting this property: The RenderingQualitySettings does not use custom quality currently. To use custom quality, set RenderingQuality property to RenderingQuality.Custom. |