Sets the extents to match the curve.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2016
Syntax
C# |
---|
public void SetCurveInView( DatumExtentType extentMode, View view, Curve curve ) |
Visual Basic |
---|
Public Sub SetCurveInView ( _ extentMode As DatumExtentType, _ view As View, _ curve As Curve _ ) |
Visual C++ |
---|
public: void SetCurveInView( DatumExtentType extentMode, View^ view, Curve^ curve ) |
Parameters
- extentMode
- Type: Autodesk.Revit.DB..::..DatumExtentType
The extent type.
- view
- Type: Autodesk.Revit.DB..::..View
The view.
- curve
- Type: Autodesk.Revit.DB..::..Curve
The curve.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | The datum plane cannot be visible in the view. -or- The curve is unbound or not coincident with the original one of the datum plane. |
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |