Verifies that boundary represents one closed curve loop without self-intersections,
consisting of non-zero length straight lines in a plane parallel to the view plane.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2014
Syntax
C# |
---|
public bool IsCropRegionShapeValid( CurveLoop boundary ) |
Visual Basic |
---|
Public Function IsCropRegionShapeValid ( _ boundary As CurveLoop _ ) As Boolean |
Visual C++ |
---|
public: bool IsCropRegionShapeValid( CurveLoop^ boundary ) |
Parameters
- boundary
- Type: Autodesk.Revit.DB..::..CurveLoop
The crop boundary.
Return Value
True if the passed crop boundary represents one closed curve loop without self-intersections, consisting of non-zero length straight lines in a plane parallel to the view plane.
Remarks
Curves in boundary use model coordinates.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |