ViewCropRegionShapeManagerIsCropRegionShapeValid Method |
Verifies that boundary represents one closed curve loop without self-intersections,
consisting of non-zero length straight lines in a plane parallel to the view plane.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic bool IsCropRegionShapeValid(
CurveLoop boundary
)
Public Function IsCropRegionShapeValid (
boundary As CurveLoop
) As Boolean
public:
bool IsCropRegionShapeValid(
CurveLoop^ boundary
)
member IsCropRegionShapeValid :
boundary : CurveLoop -> bool
Parameters
- boundary CurveLoop
-
The crop boundary.
Return Value
Boolean
True if the passed crop boundary represents one closed curve loop without self-intersections,
consisting of non-zero length straight lines in a plane parallel to the view plane.
Exceptions
Remarks
Curves in boundary use model coordinates.
See Also