Creates a simple hatch fill pattern based on the given name, angle, spacing, FillPatternTarget and FillPatternHostOrientation.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public FillPattern( string name, FillPatternTarget target, FillPatternHostOrientation orientation, double angle, double spacing1 ) |
Visual Basic |
---|
Public Sub New ( _ name As String, _ target As FillPatternTarget, _ orientation As FillPatternHostOrientation, _ angle As Double, _ spacing1 As Double _ ) |
Visual C++ |
---|
public: FillPattern( String^ name, FillPatternTarget target, FillPatternHostOrientation orientation, double angle, double spacing1 ) |
Parameters
- name
- Type: System..::..String
The name.
- target
- Type: Autodesk.Revit.DB..::..FillPatternTarget
The fill pattern target.
- orientation
- Type: Autodesk.Revit.DB..::..FillPatternHostOrientation
The fill pattern orientation.
- angle
- Type: System..::..Double
The angle.
- spacing1
- Type: System..::..Double
The spacing.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |