The types of orientations for fill patterns.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2012
Syntax
C# |
---|
public enum FillPatternHostOrientation |
Visual Basic |
---|
Public Enumeration FillPatternHostOrientation |
Visual C++ |
---|
public enum class FillPatternHostOrientation |
Members
Member name | Description |
---|---|
ToView | All patterns share the same orientation and origin with respect to view, so they perfectly align at element transitions. |
AsText | Mimics the behavior of text. Patterns align with the host and share the same origin with respect to view. |
ToHost | Patterns align with the host and compute a origin to fit the host. |