Represents a fill pattern object.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public class FillPattern : IDisposable |
Visual Basic |
---|
Public Class FillPattern _ Implements IDisposable |
Visual C++ |
---|
public ref class FillPattern : IDisposable |
Remarks
Fill patterns control the appearance of surfaces that are cut or shown in projection.
A simple fill pattern consists of a series of parallel or orthogonal lines.
Note - Dots are coded as zero-length dashes in the fill pattern definition.
When the Revit graphic engine encounters a zero-length line it simply ignores it and doesn't draw anything.
So call ExpandDots() for the patterns you construct to convert dots to small dashes, so that the rendering of the FillPattern is correct.
Inheritance Hierarchy
System..::..Object
Autodesk.Revit.DB..::..FillPattern
Autodesk.Revit.DB..::..FillPattern