Adds a CommandLink associated to the given id, displaying the indicating main content.
Namespace: Autodesk.Revit.UIAssembly: RevitAPIUI (in RevitAPIUI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2011
Syntax
C# |
---|
public void AddCommandLink( TaskDialogCommandLinkId id, string mainContent ) |
Visual Basic |
---|
Public Sub AddCommandLink ( _ id As TaskDialogCommandLinkId, _ mainContent As String _ ) |
Visual C++ |
---|
public: void AddCommandLink( TaskDialogCommandLinkId id, String^ mainContent ) |
Parameters
- id
- Type: Autodesk.Revit.UI..::..TaskDialogCommandLinkId
The id of the CommandLink. This corresponds to the value returned by Show() when the link is chosen by the user.
- mainContent
- Type: System..::..String
The main content of the CommandLink.
Remarks
Parameter mainContent cannot contain newlines.
If the id has already been set to the task dialog, the new CommandLink definition overrides the old one.
CommandLinks will always be shown in the dialog in the order of their ids.