TaskDialogAddCommandLink(TaskDialogCommandLinkId, String) Method |
Adds a CommandLink associated to the given id, displaying the indicating main content.
Namespace: Autodesk.Revit.UIAssembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic void AddCommandLink(
TaskDialogCommandLinkId id,
string mainContent
)
Public Sub AddCommandLink (
id As TaskDialogCommandLinkId,
mainContent As String
)
public:
void AddCommandLink(
TaskDialogCommandLinkId id,
String^ mainContent
)
member AddCommandLink :
id : TaskDialogCommandLinkId *
mainContent : string -> unit
Parameters
- id TaskDialogCommandLinkId
- The id of the CommandLink. This corresponds to the value returned by Show() when the link is chosen by the user.
- mainContent String
- The main content of the CommandLink.
Remarks Parameter mainContent cannot contain newlines.
If the id has already been set to the task dialog, the new CommandLink definition overrides the old one.
CommandLinks will always be shown in the dialog in the order of their ids.
See Also