Returns the name of the parent of the linked model, or an empty FilePath if the link is a top-level link.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:  2013

Syntax

C#
public ModelPath GetParentModelName()
Visual Basic
Public Function GetParentModelName As ModelPath
Visual C++
public:
ModelPath^ GetParentModelName()

Remarks

This function is only relevant for LinkLoadResult object for RvtLinkSymbol. ie. when getIsRvtLink() is true.

See Also