Sets the offset distance between the constrained RebarConstrainedHandle and its target Rebar handle surface.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2020.1
Syntax
C# |
---|
public void SetDistanceToTargetRebar( double distanceToTargetRebar ) |
Visual Basic |
---|
Public Sub SetDistanceToTargetRebar ( _ distanceToTargetRebar As Double _ ) |
Visual C++ |
---|
public: void SetDistanceToTargetRebar( double distanceToTargetRebar ) |
Parameters
- distanceToTargetRebar
- Type: System..::..Double
The distance is given as an offset value, the sign of which depends on the target bar handle direction.
Remarks
Throws exception if the constraint is not to other rebar or if the target constraint is to bar bend or hook bend.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | The given value for distanceToTargetRebar must be no more than 30000 feet in absolute value. |
Autodesk.Revit.Exceptions..::..DisabledDisciplineException | None of the following disciplines is enabled: Structural. |
Autodesk.Revit.Exceptions..::..InvalidOperationException | RebarConstraint is no longer valid. -or- The RebarConstraint is not of RebarConstraintType 'ToOtherRebar.' -or- The RebarTargetConstraintType is 'HookBend' or 'BarBend'. |