RebarConstraintSetDistanceToTargetRebar Method |
Sets the offset distance between the constrained RebarConstrainedHandle and its target Rebar handle surface.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic void SetDistanceToTargetRebar(
double distanceToTargetRebar
)
Public Sub SetDistanceToTargetRebar (
distanceToTargetRebar As Double
)
public:
void SetDistanceToTargetRebar(
double distanceToTargetRebar
)
member SetDistanceToTargetRebar :
distanceToTargetRebar : float -> unit
Parameters
- distanceToTargetRebar Double
-
The distance is given as an offset value, the sign of which depends on the target bar handle direction.
ExceptionsException | Condition |
---|
ArgumentOutOfRangeException |
The given value for distanceToTargetRebar must be no more than 30000 feet in absolute value.
|
InvalidOperationException |
RebarConstraint is no longer valid.
-or-
The RebarConstraint is not of RebarConstraintType 'ToOtherRebar'.
-or-
The RebarTargetConstraintType is 'HookBend' or 'BarBend'.
|
Remarks
Throws exception if the constraint is not to other rebar or if the target constraint is to bar bend or hook bend.
See Also