A text string that identifies the creating application.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2017
Syntax
C# |
---|
public string ApplicationId { get; set; } |
Visual Basic |
---|
Public Property ApplicationId As String Get Set |
Visual C++ |
---|
public: property String^ ApplicationId { String^ get (); void set (String^ value); } |
Remarks
The creating application may use any text string as appropriate for its purposes, or leave this property unset.
One option is to use Application.ActiveAddInId for a unique application id, or concatenate it with an application name for a more informative, but still unique id.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | When setting this property: A non-optional argument was NULL |