DirectShapeApplicationId Property |
A text string that identifies the creating application.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic string ApplicationId { get; set; }
Public Property ApplicationId As String
Get
Set
public:
property String^ ApplicationId {
String^ get ();
void set (String^ value);
}
member ApplicationId : string with get, set
Property Value
String
Exceptions
Remarks
The creating application may use any text string as appropriate for its purposes, or leave this property unset.
One option is to use Application.ActiveAddInId for a unique application id, or concatenate it with an application name for a more informative, but still unique id.
See Also