Gets the ids of all subregion elements hosted on this topography surface.
Namespace: Autodesk.Revit.DB.ArchitectureAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2014
Syntax
C# |
---|
public IList<ElementId> GetHostedSubRegionIds() |
Visual Basic |
---|
Public Function GetHostedSubRegionIds As IList(Of ElementId) |
Visual C++ |
---|
public: IList<ElementId^>^ GetHostedSubRegionIds() |
Return Value
The hosted subregion ids.
Remarks
This applies to a TopographySurface element (not a SiteSubRegion or a topography surface associated with a BuildingPad).
This applies to TopographySurface and SiteSubRegion elements.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..InvalidOperationException | This element is not a TopographySurface. |