Adds references to the connection.
All references should be of applicable category.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2017
Syntax
C# |
---|
public void AddReferences( Document document, IList<Reference> picks ) |
Visual Basic |
---|
Public Sub AddReferences ( _ document As Document, _ picks As IList(Of Reference) _ ) |
Visual C++ |
---|
public: void AddReferences( Document^ document, IList<Reference^>^ picks ) |
Parameters
- document
- Type: Autodesk.Revit.DB..::..Document
The document.
- picks
- Type: System.Collections.Generic..::..IList<(Of <(<'Reference>)>)>
The array containing picks of input elements to be added.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | One or more picks was not permitted to be add to the connection. -or- One or more picks was not permitted to be added to the connection. Picks should not be duplicated. |
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |