StructuralConnectionHandlerAddReferences Method |
Adds references to the connection.
All references should be of applicable category.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic void AddReferences(
Document document,
IList<Reference> picks
)
Public Sub AddReferences (
document As Document,
picks As IList(Of Reference)
)
public:
void AddReferences(
Document^ document,
IList<Reference^>^ picks
)
member AddReferences :
document : Document *
picks : IList<Reference> -> unit
Parameters
- document Document
-
The document.
- picks IListReference
-
The array containing picks of input elements to be added.
ExceptionsException | Condition |
---|
ArgumentException |
One or more picks was not permitted to be add to the connection.
-or-
One or more picks was not permitted to be added to the connection.
Picks should not be duplicated.
|
ArgumentNullException |
A non-optional argument was null
|
See Also